Suche

msch 29.06.2016 - 13:38

custom_nodename rückgängig machen?

Was muss gemacht werden, um den custom_nodename rückgängig zu machen, sprich: die Box wieder mit dem dyndns von Protonet zu betreiben?

 

Zuletzt bearbeitet: 15.12.2016 - 9:37

11 Antworten

Micha 29.06.2016 - 13:41

Hallo msch,
einfach in den SOUL Einstellungen die protonet.info-Adresse wieder aktivieren 😉

Herzliche Grüße
Micha

msch 29.06.2016 - 13:50

Danke, hatte ich gemacht, wollte nur eine Bestätigung, dass dies ausreicht. Hintergrund meiner Frage: nach der Umstellung auf eigene (feste) IP und eigene Subdomain gibt mir das letsencyrpt skropt folgende Fehlermeldung aus:

Error. Box is not reachable via intern.domain.tld. Please set DNS records or wait till nameservers have received the update.

Ein ping sagt aber etwas anderes:

PING intern.domain.tld (xx.xxx.xxx.xx) 56(84) bytes of data.
64 bytes from xx.xxx.xxx.xx: icmp_req=1 ttl=63 time=0.394 ms

msch 29.06.2016 - 14:00

Habe eben nochmla nachgeschaut: das skript gibt noch weitere Fehler aus:

— Custom domain intern.domain.tld correctly set at /etc/protonet/nodenames/custom
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 –:–:– –:–:– –:–:– 0curl: (60) SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a „bundle“
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn’t adequate, you can specify an alternate file
using the –cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you’d like to turn off curl’s verification of the certificate, use
the -k (or –insecure) option.
/usr/local/bin/letsencrypt: 15: [: =: argument expected
— Error. Box is not reachable via intern.domain.tld. Please set DNS records or wait till nameservers have received the update.

msch 29.06.2016 - 14:00

Ergänzung: meine domain ist natürlich nicht intern.domain.tld (das ist nur ein Platzhalter).

msch 29.06.2016 - 17:09

Ich glaube, Euer Skript „letsencrypt“ kann nicht funktionieren, denn ihr fragt ident.me ab – deren Zertifikat ist am 27.06.2016 abgelaufen!

https://ident.me/

Micha 29.06.2016 - 17:56

Danke fürs Teilen msch!

Das ist tatsächlich noch nicht aufgefallen.

Wir schauen, ob wir da noch eine Änderung in SOUL 2.16 reinbekommen, so dass niemand Hand anlegen muss.

Herzliche Grüße
Micha

msch 29.06.2016 - 17:40

Wer eine schnelle Lösung möchte:

mit SSH auf die Box.

nano /usr/local/bin/letsencrypt

und unter

RESOLVE_IP=$(dig +short $CUSTOM_DOMAIN A | tail -n 1)

folgende Zeile mit # auskommentieren:

# MY_IP=$(curl https://ident.me/)
# MY_IP=RESOLVE_IP

#if [ $RESOLVE_IP = $MY_IP ]; then
# echo „— Box is reachable from the outside via $CUSTOM_DOMAIN“
#else
# echo „— Error. Box is not reachable via $CUSTOM_DOMAIN. Please set DNS records or wait till nameservers have received the update.“
# exit 1;
#fi

mit STRG O speichern und STRG X beenden.

Dann klappt auch die Zertifikatgenerierung 🙂

msch 29.06.2016 - 17:41

folgende ZeileN auskommentieren.

msch 29.06.2016 - 23:27

Ident.me hat offenbar das abgelaufene ssl-Zertifikat erneuert. Sollte also wieder klappen.

Micha 30.06.2016 - 14:33

schaut leider heute nicht mehr so aus.. wir fixen gerade das script. Heute sollte eh ein SOUL Update raus

msch 30.06.2016 - 16:10

Korrekt. Als http-Abfrage klappt es, als https-Abfrage leider aufgrund des abgelaufenen Zertifikates nicht.