Suche

sebastianb 06.03.2017 - 19:43

SMTP ohne SMTP-Auth

Hallo,

für einen Email-Versand über die Office365-Server an unsere User muss kein SMTP-Auth durchgeführt werden. Wie konfiguriere ich das?

„none“ oder keine Angabe habe ich in der /etc/protonet/mail/smtp/authentication schon ausprobiert, leider ohne Erfolg (erwartungsgemäß):

/usr/local/rvm/rubies/ruby-2.2.3/lib/ruby/2.2.0/net/smtp.rb:771:in `check_auth_method‘: wrong authentication type  (ArgumentError)

Mit z.B. „PLAIN“ erhalte ich einen Fehler vom SMTP-Server:

/usr/local/rvm/rubies/ruby-2.2.3/lib/ruby/2.2.0/net/smtp.rb:976:in `check_auth_response‘: 504 5.7.4 Unrecognized authentication type (Net::SMTPAuthenticationError)

Ein Telnet auf einen der Mailserver gibt auch keinen Auth-Mechanismus vor:

220 VE1EUR02FT051.mail.protection.outlook.com Microsoft ESMTP MAIL Service ready at Mon, 6 Mar 2017 18:35:19 +0000
ehlo office
250-VE1EUR02FT051.mail.protection.outlook.com Hello [xxx.xxx.xxx.xxx] 250-SIZE 157286400
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-8BITMIME
250-BINARYMIME
250 CHUNKING

Grüße
Sebastian

Zuletzt bearbeitet: 13.03.2017 - 21:33

8 Antworten

Micha 06.03.2017 - 19:52

Hallo Sebastian,

am besten mal parallel bei Microsoft nachhaken – die sollten das ja auf jeden Fall wissen.
Und hier durchfräsen:
https://www.google.de/#q=mail.protection.outlook.com+%2Bauthentication

Ich würde es außerdem noch mit „login“ versuchen, dabei STARTTLS ein und Port 587 wählen.

Herzliche Grüße
Micha

sebastianb 06.03.2017 - 20:01

Hallo Micha,

login, starttls und ports habe ich schon durchprobiert.Es ist definitiv port 25.

login, starttls und 587 gibt nur timeout:
/usr/local/rvm/rubies/ruby-2.2.3/lib/ruby/2.2.0/net/smtp.rb:541:in `initialize‘: execution expired (Net::OpenTimeout)

Zumal das nicht das erste System ist, das ich so konfiguriere. Hier laufen mehrere Systeme die auf diese Weise Notifications versenden (Linux-Server und ein Multifunktionsgerät).

Maßgebend ist dieser Artikel: https://support.office.com/en-us/article/How-to-set-up-a-multifunction-device-or-application-to-send-email-using-Office-365-69f58e99-c550-4274-ad18-c805d654b4c4

Option 3. Authentifizierung über einen Connector in O365, deswegen auch SMTP ohne auth.

Grüße
Sebastian

Markus Badberg 07.03.2017 - 9:31

Hallo Sebastian,

natürlich kommt bei einer Telnet Anfrage auf Port 587 ein Timeout, weil er auf Benutzername und Kennwort wartet.

Die Office 365 Server unterstützen Port 25 und 587, und die „LOGIN“ Methode.
STARTTLS muss aktiviert sein, in der Konfiguration der Protonetbox.

Dann noch Benutzername und Passwort.

Hast Du probiert, nach der Einrichtung die Box einmal neuzustarten und dann geschaut, ob E-Mails verschickt werden?

Schöne Grüße,

*Edit

Onlinehelp24 07.03.2017 - 9:46

Hi Sebastian,

wir hatten einmal einen ähnlichen Fall. Um eine Verbindung ohne Authentifizierung herzustellen zu können, müssten wir folgendes machen.

Löschen der Dateien:

– authentication
– user_name
– password

Hilft das auch in deinem Fall?

Viele Grüße, Burkart

Burkart Orlowski

`Making IT systems work`

——————————
OH24 GmbH
Eifflerstraße 43 || 22769 Hamburg
GF: Burkart Orlowski || RN: HRB 140334 || RG: Amtsgericht Hamburg || Sitz: Hamburg

Email: b.orlowski@onlinehelp24.net || PGP Key ID: 0xDD31D108
Telefon: +49 40 69635272-0
Mobil: +49 162 2110111

Web: http://www.onlinehelp24.net | Facebook: http://www.facebook.com/onlinehelp24 | Blog: http://blog.onlinehelp24.net

sebastianb 07.03.2017 - 14:31

Hey Burkart,

Dateien löschen… Das war natürlich zu offensichtlich! *rolleyes*

Hat geklappt! Die Lösung für alle Suchenden:

/etc/protonet/mail/smtp $ ll
total 28
drwxr-xr-x 2 protonet protonet 4096 Mar 7 14:25 ./
drwxr-xr-x 3 protonet protonet 4096 Mar 6 18:41 ../
-rw-r–r– 1 protonet protonet 37 Mar 6 18:41 address
-rw-r–r– 1 protonet protonet 9 Mar 6 18:42 domain
-rw-r–r– 1 protonet protonet 5 Mar 6 19:39 enable_starttls_auto
-rw-r–r– 1 protonet protonet 3 Mar 6 19:56 port
-rw-rw-r– 1 protonet protonet 18 Mar 6 18:45 sender

Datei-Inhalte:

$ cat address
your-domain.mail.protection.outlook.com

$ cat domain
your.domain

$ cat enable_starttls_auto
true

$ cat port
25

$ cat sender
protonet@your.domain

Grüße
Sebastian

Torben 07.03.2017 - 14:38

Hey Sebastian,

lautet der Absender dann in deinen Mails auch „protonet@your.domain“, oder trotzdem noch „noreply@protonet.de“?

sebastianb 07.03.2017 - 14:44

Hey Torben,

leider lautet der Absender dann noch immer „noreply@protonet.de“ – hatte ich erst nach dem Absenden gesehen. Also wird scheinbar die „sender“-config nicht beachtet in meinem Fall.

Vielleicht kann jemand von protonet da noch etwas Licht ins Dunkel bringen?

Grüße
Sebastian

Micha 07.03.2017 - 16:21

Hallo,
spontan habe ich da keine Info zu. Die sender-config sollte normalerweise gelesen werden. Ich muss prüfen lassen, ob die abhängig ist von einer der von euch entfernten Dateien. Das wird einige Tage dauern.

Herzliche Grüße
Micha