Suche

Den 14.02.2017 - 10:25

letsencrypt DNS Fehler

Hallo,

Ich bekomme folgenden Fehler beim ausführen von letsencrypt:

Error. Box is not reachable via sub.domain.de. Please set DNS records or wait till nameservers have received the update.

DNS ist weltweit bekannt, die Box ist auch über die neue Adresse erreichbar.

Wir haben mehrere Externe IP Adressen. Hab irgendwo im Forum gelesen das Letsencrypt-Script macht irgendwas mit https://ident.me/ . Wenn ich das aufrufe wird mir eine IP angezeigt, welche nicht für den Zugriff auf die Protonetbox verwendet wird. Kann das das Problem sein? Was kann ich dagegen tun?

Danke!

Dennis

Zuletzt bearbeitet: 14.02.2017 - 11:44

6 Antworten

Den 14.02.2017 - 10:48

Habs mit folgender Anleitung aus einem anderen Forenpost gelöst:

Wer eine schnelle Lösung möchte:

mit SSH auf die Box.

nano /usr/local/bin/letsencrypt

und unter

RESOLVE_IP=$(dig +short $CUSTOM_DOMAIN A | tail -n 1)

folgende Zeile mit # auskommentieren:

# MY_IP=$(curl https://ident.me/)
# MY_IP=RESOLVE_IP

#if [ $RESOLVE_IP = $MY_IP ]; then
# echo „— Box is reachable from the outside via $CUSTOM_DOMAIN“
#else
# echo „— Error. Box is not reachable via $CUSTOM_DOMAIN. Please set DNS records or wait till nameservers have received the update.“
# exit 1;
#fi

mit STRG O speichern und STRG X beenden.

Dann klappt auch die Zertifikatgenerierung ?

msch 14.02.2017 - 16:17
qnze 15.02.2017 - 9:50

Danke für den Hinweis. Bei mir lief letsencrypt es ebenfalls nicht, trotz des korrekten CNAME-Eintrags. Nun haut’s hin…

carmei 14.02.2017 - 11:03

Moin,
das Problem hatte ich auch: Meine sub.domain.de leitet auf eine feste IP-Adresse weiter, an der die Box hängt.
Lösung: Die IP-Adresse muss in den DNS-Einträgen der Sub-Domain als CNAME bzw. als „andere IP-Adresse/IPv4-Adresse“ eingetragen werden. Eine einfache HTTP-Weiterleitung funktioniert nicht. Erkennst Du daran, dass nach Aufruf deiner Sub-Domain in der Browser-Zeile nicht die IP-Adresse, sondern die Sub-Domain weiterhin angezeigt wird.
Danach ist bei mir auch das letsencrypt fehlerfrei durchgelaufen und die Box ist über https auf meine Sub-Domain erreichbar.

Gruß
Carsten

Den 14.02.2017 - 11:11

Die IP war als „andere IP-Adresse“ (A-Record) im DNS eingetragen, trotzdem das Problem.
Vermute immernoch die Ursache bei der „falschen“ IP die von ident.me zurückgegeben wird. Naja jetzt geht es ja durch das abschalten der Prüfung im Script…

Micha 14.02.2017 - 11:44

Thread wurde im Rahmen der Moderation in die Kategorie „Eigene Webadresse einrichten (DynDNS, …)“ verschoben.